Home : Deployment : What Environments are Supported by DotImage?
Q10289 - FAQ: What Environments are Supported by DotImage?

DotImage is now officially tested and supported on the following OS:

DESKTOP OS

  • Windows 10
  • Windows 8 (and 8.1)
  • Windows 7
  • Windows Vista

SERVER OS

  • Windows Server 2016
  • Windows Server 2012 / 2012 R2
  • Windows Server 2008 R2

Note: Windows XP and older are no longer officially supported.

DotImage supports the following .NET Framework versions:

  • 1.1 in DotImage 6.0 and lower
  • 2.0 in DotImage 3.0 through 10.3
  • 3.0 in DotImage 6.0 through 10.7
  • 3.5 in DotImage 6.0 through current version
  • 4.0 (and newer : 4.5, 4.5.1, 4.5.2, 4.6, 4.7) in DotImage 9.0 through 10.7   note 4.0, 4.5 and 4.5.1 are NOT supported in 11.0 and newer
  • 4.5.2 and newer DotImage 9.0 and up..

Our ASP.NET web viewing controls are officially tested and supported in the following browsers:

  • Internet Explorer 11 (in Document Mode: Edge)
    NOTE: Compatibility View Mode is not supported in any version of IE
  • Internet Explorer 10.0 (in Document Mode: Edge) Not supported in DotImage 11.0 and newer
    Internet Explorer 9 (In Browser Mode: IE9, Document Mode IE9 Standards only) Not supported in DotImage 11.0 and newer
  • Internet Explorer 8 (In Browser Mode: IE8, Document Mode IE8 Standards only) Not supported in DotImage 11.0 and newer
  • FireFox (current version)
  • Chrome (current version)

DotImage development is supported in :

  • Visual Studio 2003 (DotImage 6.0 and lower)
  • Visual Studio 2005 (DotImage 3.0 through 10.7)
  • Visual Studio 2008 (DotImage 6.0 through current version *)
  • Visual Studio 2010 (DotImage 9.0 through current version *)
  • Visual Studio 2012 (DotImage 10.0 through current version)
  • Visual Studio 2015 (DotImage 10.0 through current version)
  • Visual Studio 2017 (DotImage 10.7 and up)

* note that DotImage 11.0 does not support .NET 4.0, 4.5, or 4.5.1 so you must use at least VS 2012 and target .NET 4.5.2 or target .NET 3.5 with supported version of VS to use 11.0

NOTE: Support provides demos / samples for versions 10.7 and lower in VS2008 / VS2010  for 11.0 and up, we provide samples in VS2012 for desktop apps and VS2013 for web apps

 

 

Related Articles
No Related Articles Available.

Article Attachments
No Attachments Available.

Related External Links
No Related Links Available.
Help us improve this article...
What did you think of this article?

poor 
1
2
3
4
5
6
7
8
9
10

 excellent
Tell us why you rated the content this way. (optional)
 
Approved Comments...
No user comments available for this article.

Powered By InstantKB.NET v1.3
Copyright © 2002, 2018. InstantASP Ltd. All Rights Reserved